BBEdit Tutorial

(version 1)
This tutorial is designed to teach you some the basics of using BBEdit 6.

Contents
This tutorial will guide you through the following steps:

Retrieving the necessary materials from the Web
Configuring BBEdit

Creating a Web page from "scratch"

Converting a Microsoft Word document into a Web page
Editing an existing Web page

Getting your pages on the Web

Cleaning up
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Prerequisites

This tutorial assumes a level of competency with basic Macintosh computing tasks and concepts.
For example, you should know what the desktop is. You should know what the Finder is. You
should feel comfortable working with files and folders and navigating file hierarchies.

Important: You will also need to understand the basic vocabulary and syntax of HTML.

Conventions
Actions that you need to perform are bulleted, like this:
e Open the file.

Menu commands look like this: File > Open. This means choose the Open option from the File
menu. Sometimes, for the sake of brevity, common menu items may be referred to simply as
Save or Open. The same style is used for other user interface elements, such as key you're
supposed to press and buttons you're supposed to click, i.e. "Click the OK button.”

HTML code and URLs look like this:

<BODY BGCOLOR="white™>
Names of files and folders, as well as text that you are supposed to type, are rendered in italics.
Control-clicking means clicking the mouse while holding down the control key.
Option-clicking means clicking the mouse while holding down the option key.

Command-clicking means clicking the mouse while holding down the command key, sometimes
called the Apple key. That's the key that's usually right next to the space bar.
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1. Retrieve Materials

First, you must create a folder to hold your files.

* Create a new folder on the desktop and name it bbtutorial. You can do this quite simply
by control-clicking on the desktop and choosing New Folder from the pop-up menu.
Then, without pausing to draw breath, type the word bbtutorial. Press the Return key,
and you're done.

¢ Open up the folder you've just created and create another folder inside it. Name this
folder images.

Next, you must retrieve the necessary materials from the Web.
e Start Netscape, and point the browser to this URL:
http://www-xula-edu/Administrative/cat/workshops/bbedit/
e Find the section of the page under the heading Tutorial Materials.

*  Option-click on All_About_Mustard.doc and save this file in the bbtutorial folder you
created earlier. (You'll be prompted by Netscape.)

¢ Option-click on coffee.html and save this file in the bbtutorial folder.
* Option-click on mustard.jpg and save this file in the images folder.
¢ Option-click on wavetile16gzig.gif and save this file in the images folder.

You should now have a Word document, a Web page, and two image files in your bbtutorial folder
— all the materials you need to complete this tutorial.

* From the Finder menu (extreme upper right corner of the screen) choose Hide Netscape.
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2. Configuring BBEdit

As with many other programs, BBEdit gives you a lot of options for customizing the program.
Fortunately, the initial "out of the box" settings are pretty good in this author's opinion. But there
a few settings you will need to adjust. I recommend you configure BBEdit this way on your own
machine as well.

° Start BBEdit. T =] Preferences B p i iy
. 'i'h'om&_-_-um‘fm mmm-m:‘:um:: i (Ceane=i ) Save
¢ Choose Edit > Preferences. e — —
- | R =
e Use the left pane to select the FTP e ot
Bookmarks settings. TS esrynts i
T et =
e  Fill out the appropriate information b ||| temes lapeere !
in the fields as described below e P o Lt !
n the ne. . i User: [bpeverso ]
HTML Veb BIt pass: I ...... l
Printing
Sewchfaisers [ path: | ]

Name: Tutorial bookmark

Host:  webusers.xula.edu

User: [type your username here]
Pass: [type your password here]
Path: [leave this blank]

e (Click Add when finished.

You've just added the information necessary to enable BBEdit's built in FTP client. If you are
doing this tutorial on a shared computer, make sure you delete this bookmark before you leave, as
explained in the final section.

Next, you will tell BBEdit to display line numbers for all documents by default. This is helpful in
combination with syntax checking.

e  Use the left pane to select the Windows settings.
e  Make sure the Line Numbers box is checked.

Finally, you will set a local site root. This sounds complex, but it's not. Remember that for Web
authoring it's wise to build your site on you hard drive, keeping all your Web files in a single
folder. In this step, you're simply telling BBEdit where that folder is located. This allows BBEdit
to resolve relative links between your documents.

o  Use the left pane to select the HTML Web Site settings.

o (Click the Set... button under Local Site Root. Navigate to the bbtutorial folder you
created. (It's on the Desktop, remember?) Select it and click the Choose button.

e Click Save to save the new settings, then close the Preferences dialog,.
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3. Making a File Group

Most websites consist of more than one page. BBEdit allows you to group these files together so
that you can work with them conveniently. BBEdit does this by creating a special file that
contains references to other files and folders. This special file is called -- surprise -- a file group.

File groups will usually contain text and hypertext files, which can be edited in BBEdit. But as a
matter of fact, you can add any sort of file to a file group, even files which BBEdit can't edit.

o Choose File > New > File Group.
A new document window appears. It's empty, but you're about to change that.
o Click the Add Folder... button.
A dialog box opens, prompting you for the folder you wish to add to the group.
e (Click the Choose... button.
e A second dialog opens. Navigate to the bbtutorial folder and select it, then click Choose.
e The second dialog closes, returning you to the first. Click the Add button.

The bbtutorial folder should now appear in the document window. If you click that little triangle
to the left of the folder icon, the contents of the folder will be revealed.

Now save the file group:
e Choose File > Save.
e Make sure to save it in the bbtutorial folder for the sake of convenience during this
tutorial. Name it My Group of Files.

Note: Because your file group will probably never go onto a non-Mac computer, you can
name it anything you want, without regard to filename extensions and the like. Of
course with all files that you plan to put on the Web you must be more careful: avoid
spaces and funny characters, and always include the correct filename extension.

In real life, you might save a file grouping to your desktop. Then you can hide your Web folder(s)
away on your hard drive somewhere and use the file group icon as a shortcut when you want to do
some Web work.

o Leave the My Group of Files window open throught this tutorial so you can use it later.
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4. Making a Web Page from "Scratch"

4.1

Getting Started

Choose File > New > HTML Document...

A dialog should appear. Check all the boxes except Is Index.

For DOCTYPE choose HTML 4.0 Transitional from the pop-up menu.
For Title type My Fake Home Page.

Click OK.

This should give you a template like the following:

<!DOCTYPE HTHL PUBLIC "-//W3C//DTD HTHL 4.0 Transitional//EN"
"http://www.w3.0rg/TR/REC-htmlU40/loose.dtd™>
<HTML>
<HEAD>
<TITLE>My Fake Home Page</TITLE>
<META NAME="generator™ CONTENT="BBEdit 5.1.1">
</HEAD>
<BODY>

</BODY>
</HTHL>

Before going any further, save your work.

Choose File > Save and name the file home.html. Make sure you are saving it in the
bbtutorial folder.

Don't forget to add this new file to the file group. Just drag the document icon from the
home.html and drop it in the My Group of Files window, then save My Group of Files.

Next you will assign a background image for this page, then add some text.

Background images are specified as attributes of the BODY element, so click inside the
opening BODY tag.

Hint : Make sure you click inside the opening tag and not between the opening and
closing tags!

Click the Edit Tag button on the HTML tools palette. (Or choose Markup > Edit Tag.
Or press Option-Command-M. Or just control-click in the tag. There are many ways to
do the same thing, Keyboard shortcuts are the fastest, but clicking buttons in the palette
are the easiest. It's up to you to choose between the quick way and the easy way!)

A dialog box should appear. Specify a background image. But don't type the address in
manually. Click the File... button and navigate to your images folder. Select the
wavetile16gzig.gif image and click the Open button.

The Background field should now say images/wavetilelkgzig.gif (If not, make sure that
you are using Relative addressing,)

Click the Apply button to close the dialog box.

Observe that the BODY tag has changed. It should now say:

<BODY BACKGROUND="images/wavetilelbgzig.gif">

Now add some content to the page itself. You'll start with a heading, then a paragraph.
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e  Click between the BODY tags.

Hint. Don't click inside either tag. Instead, click between the two tags - in that blank
space between the opening BODY tag and the closing BODY tag. Get it?

e Press the Return button on your keyboard several times to give yourself room to work.
Then return to the first blank line.

e Click the Heading button on the HTML tools palette, and choose H1 from the pop-up
menu. (Or choose Markup > Block Elements > H1)

Note that BBEdit inserts a pair of H1 tags. The text insertion point is between the two tags, so you
can just start typing:

o Type Welcome to My Fake Home Page.
e  Use your arrow key to move down to a new blank line. (Create a new line if necessary.)

e  Click the Paragraph... button on the HTML tools palette. (Or choose Markup > Block
Elements > Paragraph...)

e A dialog box should appear, allowing you to customize your paragraph element with
different attributes. But you want a plain vanilla paragraph, so just click Apply.

¢ BBEdit inserts paragraph tags for you. Between the P tags, type some nonsense text for
your fake page.

Hint: If you type very much, you may find the window starts to scroll to the left. You can
prevent this by choosing Soft Wrap Text from the window options pop-up.

e Save your work.

Your page should now look something like this:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTHL 4.0 Transitional//EN"
"http://www.wl.org/TR/REC-html40/loose.dtd"™>
<HTML>
<HEAD>
<TITLE>My Fake Home Page</TITLE>
</HEAD>

<B0ODY BACKGROUND="images/wavetilelbgzig.gif™>

<Hl>Welcome to My Fake Home Page</H1l>

<p>

Hello and welcome to my fake home page. It's not a real page. I'm just
making it up for this dumb workshop-.

</P>

</BODY>

</HTHL>

Browsing Your Page
¢ Save your work (if you forgot to do it above).

o Click on the Preview button -- it should be the last one at the bottom of the HTML tools
palette.

BBEdit launches your Web browser of choice and shows you what your page looks like.

As you continue through the rest of this tutorial, remember to click the Preview button every so
often to see how your pages are developing.

e Return to BBEdit by using the application menu in the upper right corner of your screen.
Don't quit your browser -- you'll be using it again and again.
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More Ways to Do the Same Thing

e Click in the blank line below your paragraph (after the closing P tag). If you don't have a
blank line, create one.

e Insert some plain vanilla paragraph tags. (Remember how?)
o Between the P tags, type a sentence like this:
Some of my interests include...

e  When you're finished typing, click in the blank line below your new paragraph (after the
closing P tag). If you don't have a blank line, create one.

Now you're going to create a list. You may recall that lists in HTML are a bit more complicated
than headings and paragraphs, because they are composed of nested tags. But with BBEdit lists
are easy.

e  Click the List... button on the HTML tools palette. (Or choose Markup > Lists > List...
Or press Control-Command-L.)

o Adialog box will open. Choose the Unordered list type. Make sure that the Generate
Close Tags and Indent Items box is checked. Then click Apply.

BBEdit inserts code for an unordered list with just one list item, like this:

<uL>
<LI></LI>
</uL>

Now you could add items to the list one at a time, but that's rather awkward. In fact, it is easier to
type your list in plain text and then mark all the items up in one fell swoop.

e Choose Edit > Undo List to get rid of the markup. Or press Command-Z. Now there's a
keyboard shortcut worth memorizing! Note also that BBEdit supports multiple undos.
Each time you press Command-Z, you undo one more step.

e Now type a list in plain text. In other words, type a word or phrase and the press Return.
This is supposedly a list of your interests, but you can type anything you like, so long as
mustard and coffee are in there somewhere.

You should now have a list that looks something like this:

mustard
coffee
fine wines

e  When you're done, select the entire list. Don't skip this step, or the next step won't work.

e Click the List... button on the HTML tools palette. (Or choose Markup > Lists > List...
Or press Control-Command-L.)

e Adialog box will open. Choose the Unordered list type. Make sure that the Generate
Close Tags, Ignore Blank Lines and Indent Items box is checked. Then click Apply.

You should now have some code that looks something like this:

<uL>
<LI>mustard</LI>
<LI>coffee</LI>
<LI>fine wines</LI>
</UL>
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e Press the Return key on your keyboard a couple of times to insert a few blank lines after
the closing UL tag.

Just in case you're curious, the only reason you're inserting blank lines is to make your code easier
to read.

Now you'll add a horizontal rule and an address to round out the page.

o Choose Horizontal Rule... from the Block Elements pop-up menu in the HTML tools
palette. (Or you could choose Markup > Block Elements > Horizontal Rule...)

o In the tag editor, select Align: center, Width: 50%, Size: 1.
Make sure to check the No Shade box. In fact, check all the boxes.

e  When you're done, click Apply.
Note that BBEdit has added the following code to your page:

<HR ALIGN="center™ WIDTH="50%" SIZE="1" NOSHADE>

e Press Return to start a new line.

e Choose Address from the Block Elements pop-up menu in the HTML tools palette. (Or
you could choose Markup > Block Elements > Address.)

e BBEdit inserts a pair of ADDRESS tags for you. Now type some content for your address,
like This page was created by Jane Doe on February 31%, 2001 or something similar.

You should now have something like this:

<ADDRESS>This page was created by Jane Doe on February 31st, 200%.</ADDRESS>

e Save your work.

o See what the page looks like by clicking the Preview button.

Validation Time

e Choose Check > Document Syntax from the HTML tools palette. (Or you could use the
drop-down menu, or just press Contol-Command-Y.

If you're lucky, the results will say that there are no errors or warnings. But if you have errors,
they will be reported with details and line numbers.

o Ifyou have errors, fix them and re-validate.

o Close the results window when you are done.
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5. Converting a Microsoft Word Document

A common goal for Xavier faculty is transforming content from a word processing document into
a Web page. Microsoft Word has a Save as HTML feature, but it is universally reviled for
producing needlessly bloated files, not to mention invalid HTML.

I recommend getting the plain text from your Word document and marking it up with the
appropriate HTML tags.

One way to do this is by saving the document as a "text only" file. But there is a simpler way.

It's Called Copying and Pasting

Open the file named All_About_Mustard.doc which you saved to your bbtutorial folder.
Double-clicking the file's icon launch Microsoft Word.

Take a moment to look over the document and familiarize yourself with its contents and
general structure. It should already be familiar if you've taken the Introduction to HTML
seminar. A copy of this document is attached to the end of this tutorial; you may find it
more convenient to refer to the printed copy as you proceed.

Choose Edit > Select All to select all the text.
Choose Edit > Copy to copy the selected text.
Quit Microsoft Word and return to BBEdit.

In BBEdit, create a new document by choosing File > New > HTML Document, this time
clicking on the Blank Document icon.

A dialog should appear. Check all the boxes except Is Index.
For DOCTYPE choose HTML 4.0 Transitional from the pop-up menu.
For Title type My Mustard Page, then click OK.

Click inside the opening BODY tag, then click the Edit Tag button on the HTML tools
palette.

A dialog box should appear. Specify a BGColor (background color) of yellow, then click
Apply.

Click between the BODY tags.

Choose Edit > Paste. The text you copied from Word should appear in the new

document between the BODY tags. Note that all the special formatting has been stripped
away. All that remains is plain text and line breaks (carriage returns).
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Your document should now look something like this:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"
"http://www.-w3.org/TR/REC-html4D/loose-dtd™>

<HTHL>
<HEAD>

<TITLE>Mustard Page</TITLE>

<META NAME="generator"” CONTENT="BBEdit 5.1">
</HEAD>

<BODY BGCOLOR=T"#FFFFOO">

All About Mustard

An Abbreviated History of Mustard

The Greeks used mustard as a condiment and a drug but it was the Romans who first made real culinary
use of it by grinding the seeds and mixing the flour with wine. vinegar., o0il and honey. UWhen they
moved into Gaul they took mustard plants with them and it was in the rich wine growing region of
Burgundy that mustard flourished.

It is reputed that at a festival in 133k attended by the Duke of Burgundy and his cousin King Philip
the Fair- no less than 70 gallons of mustard were eaten. Reports do not say how pickled the guests
were.

Pope John XX11} of Avignon loved mustard so much that he created the post of "Mustard Maker to the
Pope-" a job he gave to an idle nephew who lived near Dijon. Dijon soon became the mustard centre of
the world and in fact so important was it that in 1b34 a law was passed to grant the men of the town
the exclusive right to make mustard.

1777 saw the start of mustard making as we know it today as it was in this year that Messieurs Grey
and Poupon founded their company. They used Grey's recipe and Poupon's money! UWe still owe a lot to
this redoubtable duo as in 1A50 their company invented a steam operated grinding machine so ending the
era of laborious and back-breaking hand grinding.

And as Jesus said in the Gospel of Thomas:

LThe Kingdom of Heavenl is like a mustard seed. It is the smallest of all seedss but when it falls on
tilled soil+ it produces a great plant and becomes a shelter for birds of the air.

A Mustard Recipe

Ingredients

4 Tablespoons Dry mustard powder

1 Tablespoon White Wine Vinegar

2 Tablespoons Flat beer

1 Clove Garlic

1l Teaspoon Sugar

1/2 Teaspoon Salt

1/4 Teaspoon Turmeric

1 Tablespoon 0live o0il ~- optional

Preparation
Whisk together dry mustard. vinegar and beer.
2. Use a garlic press or large pair pliers to squeeze the juice from the clove of garlic into

the mixture.
Stir in sugar. salt and turmeric.
y. To make mustard smoother and less hot. add olive oil to taste.

Mustard Links

Européenne de Condiments
http://www.moutarde.com/
A mustard company's website
s Mustard Gas
http://wuu.spartacus.schoolnet.co.uk/Flllmustard.htm
A description of mustard gas

Mount Horeb Mustard Museum
http://www.-mustardweb.com/
The world's largest collection of prepared mustards
</BODY>
</HTHML>

e Save the file as mustard.html in your bbtutorial folder.

You've just created another Web page. It's incomplete, to be sure, but take a moment to see how
it looks in a Web browser:

e Click the Preview button.

Note how all the text runs together. All the extra whitespace and line breaks are ignored by the
browser. You have not yet marked up any of the text, and so the text has no logical structure.

e Return to BBEdit. (Don't quit your browser.)

10
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Marking Block-Level Elements

Now you will designate the basic structure of the text. Each chunk of text must be designated as
belonging to a block element such as a heading or a paragraph.

e  Select the first heading. That's the line which reads All About Mustard.

Hint. To select an entire line quickly, triple-click in that line.

¢ Sinceit's the heading for the whole page, mark it as a first-level heading
using any of the methods described above.

The line should now appear as:

<H1>All About Mustard</Hl>

Now you must continue to mark up the rest of the text. This procedure requires you to exercise
some judgment. Refer to the printed Word document and other materials as you need them. You
should save your work often, and check your work in the browser often.

Hint: For cleaner, easier-to-read markup, insert carriage returns liberally, whenever you
need them. Remember that they will not be visible in the browser.

Here are some suggested steps toward marking up the complete document:

e Mark all the headings. Remember that headings range from H1 (most important) to Hk
(least important). You've already marked a first-level heading, so mark up some second-
and third-level ones.

e Mark all the paragraphs. You'll want to use the Paragraph button to mark up multiple
paragraphs.

Hint: There are six paragraphs total, and they're all in the first section of the document.
Yes, the extended quotation is a paragraph.

e  Mark the extended quotation with BL 0CKQUOTE tags.

Hint Number One: Try the Block Elements button to find this and other less-frequently
used tags. Or use the Tag Maker button. Or press command-M.

Hint Number Two: The BL0CKQUOTE tags should surround the P tags like so:

<BLOCKQUOTE>

<P>

[The Kingdom of Heavenl is like a mustard seed. It is the smallest of all
seedss but when it falls on tilled soil. it produces a great plant and
becomes a shelter for birds of the air.

</P>

</BLOCKQUOTE>

e Don't mark the ingredients as a list. Instead mark this as a section of preformatted text
with the PRE tag.

Hint: See Hint Number One above.

e To mark the ordered list (the one that is numbered), first delete the numbers. (For extra
credit: Why?) Then select the entire list, and mark it up just as you marked up the
ordered list on the other page. But this time check the "Ordered" option.

11
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Dealing with Tricky Text

The list of links presents some special challenges:

You may see * or § or other characters as bullets, an artifact of pasting a from Word.
Delete these characters.

Select the list and mark it up as unordered.

Save, then click the Preview button.

Notice that each line in the list has been marked up as a separate bulleted item. Compare this to
the original Word document and you will see this is not what you want. In fact, there should only
be three bulleted items in this list, each one consisting of multiple lines. There are several ways to
achieve the desired effect. Her's one:

Return to BBEdit and Undo the list.
Make sure there's a blank line between each set of three lines.

Select all three items (three lines for each of three items + two blank lines = eleven lines
total).

Choose Text > Remove Line Breaks.

BBEdit strips away carriage returns. There should be only three lines, like this:

Européenne de Condiments http://www.moutarde.com/ A mustard company’s...
Mustard Gas http://www.spartacus.schoolnet.co.uk/FWlmustard.htm A ..

Mount Horeb Mustard Museum http://www-mustardweb.com/ The world's ...

Hint: Use the Text Options button and make sure that Soft Wrap Text is turned off for
this task. You can turn it on again later.

Select the entire list. Make it into an unordered list.

Save and Preview.

OK, now there's three bullets. That's progress. But it still needs some line breaks.

Return to BBEdit.

Insert line breaks -- the BR tag -- in the appropriate places. Just click where you want the
line break to appear, then choose Break... from the Inline Elements button on the HTML
Tools palette. (Or click the Tag Maker... button. Or press command-M.) I recommend
pressing the Return key after each BR tag you insert just to make the code easier to read.

When you're done you should have something that looks like this:

<yL>
<LI>Européenne de Condiments <BR>
http://www.moutarde.com/ <BR>
A mustard company’s website</LI>
<LI>Mustard Gas <BR>
http://www-spartacus.schoolnet.co.uk/FiiWmustard.htm <BR>
A description of mustard gas</LI>
<LI>Mount Horeb Mustard Museum <BR>
http://www.mustardweb.com/ <BR>
The world's largest collection of prepared mustards</LI>
</UL>

Save and then click the Preview button.

Great. It looks more or less like the original Word document now.

12
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e Add a horizontal rule at the end of the page (the HR tag). It's a block element. Can you
figure out how to add it?

e Save and Preview.

Designating Links

But come to think of it, this is a Web page, not a printed sheet of paper. Why not make those
URLs into clickable links?

e Return to BBEdit.
e Select the first URL.
e  Click the Anchor button on the HTML Tools palette.

A dialog box opens. The URL should appear in the Href box. You can use this dialog box to enter
any URL and link any text, but BBEdit is "smart" enough to know what you intend in this case.

o  Click the Apply button.
BBEdit adds an anchor tag around the URL.
e Repeat this procedure on the other two URLs in the list.
¢ Save and Preview.
The URLs should appear as clickable links. Go ahead and check to see if they work.

Re-using Code

Now you just need to add a footer similar to the one you created for home.html. In fact, why type
all that over again when you can copy and paste?

e Return to BBEdit.

e Return to home.html. If it's open but not visible, try the Window menu. If it's not open,
look under File > Open Recent.

e Select the HR and ADDRESS elements from the bottom of the page.
¢ Copy. (All Mac users know how to do this, right?)

e Return to mustard.html and Paste the copied text toward the bottom of the page, taking
care to place it before the closing BODY tag.

Marking Inline Elements

Anchors or links are examples of inline elements (as opposed to block elements). So are line
breaks. Now you will continue to designate the structure of the text at the inline level --
sometimes referred to as the "text level." BBEdit's HTML Tools palette puts some of these
functions under Inline Elements, while others are located under Phrase Elements or Font Style
Elements.

o Select the phrase 70 gallons.
e Choose Emphasis from the Phrase Elements pop-up button.
Note that the phrase is marked with EM tags to indicated emphasized text.

e  Mark the phrase Gospel of Thomas as a citation with the CITE tag.
(I'll let you figure out a way to do this on your own.)

13
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Images are inline elements too. Adding images with BBEdit is pretty easy, and as per usual there
are a few different ways to accomplish this. You could, for example, click the Image... button in
the HTML Tools palette. But here's another way, the popular drag-n-drop method:

o  Position My Group of Files to the left side of your screen.
o  Position mustard.html to the other side of your screen.

You should be able to see both My Group of Files and your mustard.html side by side. If you
can't, make the necessary adjustments.

e In mustard.html insert a blank line just after the opening BODY tag.
e Drag mustard.jpg from My Group of Files and drop it in the blank line you just inserted.

BBEdit understands that you want to add the image to the page and opens the Image Drop
Options Dialog box.

e Check the Relative option and type mustard plant in the Alt Text box, checking the Use
and Include Size options as well.

e  When you're done, click the Insert button.
BBEdit writes the following HTML for you:

<ING SRC="images/mustard.jpg™ ALT="" BORDER="O">

Validation Time

e Choose Check > Document Syntax from the HTML tools palette. (Or you could use the
drop-down menu, or just press Contol-Command-Y.

The HTML Syntax Errors window should open with at least one error:

Error: File mustard.htmli line 99:
Unencoded entity foundj "é" needs to be encoded as "&#%eacutesi”.

It's that diacritical mark in Européenne that's causing the problem. Extended characters of this
sort should be encoded to ensure that they display properly. This is because of the bewildering
variety of text-encoding schemes used by the bewildering variety of computers connected to the
Internet.

e Close the HTML Syntax Errors window.
o  Select the é in Européenne.
e Choose Window > Palettes > Entitites.

The HTML Entities palette opens. The character you've selected is highlighted in the list, right
beside its proper encoding.

e Click Insert and dismiss the palette.

Note that the problematic text should now read Europ&eacute;enne. The character has been
encoded.

¢ Choose Check > Document Syntax from the HTML tools palette. (Or you could use the
drop-down menu, or just press Contol-Command-Y.

The "Unencoded entity" error should not appear this time.

e Ifyou have other errors, fix them, then Save your work.

14



HomeSite Tutorial

6. Editing an Existing Page
Most Web pages get updated from time to time. This section focuses on how you can use BBEdit
to edit a Web page which already exists.

Open coffee.html. (Choose File > Open to do this.)

Preview the page just to see what it looks like.

Return to BBEdit.

Control-click in the opening B0DY tag and choose Edit Tag....
Choose a dark brown color for the background.

Choose white for the text color.

Click OK.

BBEdit inserts the appropriate attributes and hex values for the color you chose. Your BODY tag
should now look something like this:

<B0DY BGCOLOR="#Lb3300" TEXT="#FFFFFF">

Of course, the precise hex value you chose may vary.

Save, Preview, then return to BBEdit.

6.1 More Tag Editing

Control-click in the opening H1 tag and choose Edit Tag from the pop-up menu.
Choose Center for the Align attribute, make sure the box is checked, then click OK.
Save, Preview, observe the change, then return to BBEdit.

Control-click in the opening TABLE tag and choose Edit Tag from the pop-up menu.
Check the Padding box and type 5.

Check the Spacing box and type o (zero).

Click the Apply button.

Control-click in the first opening TR tag and choose Edit Tag from the pop-up menu.
Check the BGColor box and select black from the pop-up menu, then click Apply.

Save, Preview, observe the change, then return to BBEdit.

Validate the document and correct any errors.

6.2 Linking Documents

Return to home.html. If it's open but not visible, try the Window menu. If it's not open,
look under File > Open Recent.

In the list of your interests, double-click on the word mustard to select it. (Just select the
word, not any code.)

From My Group of Files, drag mustard.html into the home.html and drop it onto the
word mustard. (You may need to jockey some windows into position.)

BBEdit opens the Anchor Drop Options dialog box.
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e  Make sure the Relative option is checked, then click Insert.
BBEdit writes the appropriate HTML to make the link.

e Repeat the process to link the word coffee with the file coffee.html

e Check Syntax and correct any errors.

e Check Links (can you find the button?). This feature makes sure all your local links are
working, including image tags, but it does not check links to other websites.

e Save, Preview.

6.3 Extra Credit

e Ifyou have time, make your own table using the Table button.
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7. Uploading Your Praoject

7.1

7-3

The next step is to put these files on the Web. To do this, they must be uploaded from your
desktop computer to one of the Xavier Web servers.

The server designated for personal pages is named webusers.xula.edu. Your home directory is on
this server. It was created with your Xavier e-mail account.

Remember that "directory” is just another term for "folder.”

You may already be familiar with using File Transfer Protocol or FTP to upload your files to the
server. If so, you probably use an FTP client like Fetch or a similar program.

BBEdit has an FTP client built into it, which makes uploading files to the server almost as easy as
saving files to your hard drive.

Saving to an FTP Server
e In BBEdit, with home.htinl as the active window, choose File > Save to FTP Server...

e In the resulting dialog window, choose Tutorial bookmark from the Bookmarks pop-up
menu. (This is the bookmark you added way back in the beginning when you configured
the preferences.) Then click the Connect button.

e  After a brief pause as BBEdit conencts to webusers.xula.edu, you should see a listing of
files in your account. If you get an error message, you may have entered the wrong
password.

e  We want to the file structure on the Web server to mirror the file structure you've created
on your Mac. So, to that end, click New Dir to create a new directory (folder) and name it
bbtutorial.

It may take a second, but BBEdit will create a new directory on the server, and then change to that
directory listing. Of course the directory will be empty, but it should say bbtutorial on the pop-up
menu.

e Click Save to save your file in the bbtutorial folder.
¢  Repeat this process with mustard.html and coffee.html.

BBEdit's Fatal Flaw?

BBEdit can only upload text files. What about your two image files? You will have to upload them
using with another program, alas.

e Use Fetch (or any FTP application) to upload your image files to the bbtutorial directory
you created on the server.

The Moment of Truth

e Point your Web browserto http://xavier.xula.edu/username/bbtutorial/
(but replace username with your username)

You should see your fake home page. Congratulations -- you're a webmaster.
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8. Cleaning Up

Your username and password recorded in the preferences, so you definitely do not want to leave
this information on a shared lab computer.

e Choose Edit > Preferences.

e  Use the left pane to select the FTP Bookmarks settings.
o Delete the Tutorial bookmark.

o (Click Save, then quit BBEdit.

o  Drag your bbtutorial folder to the Trash.

e Empty the Trash.

e  Shut down your computer.

¢ Don't forget to turn off your monitor too!

e Please fill out an evaluation form before you leave.
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All About Mustard

An Abbreviated History of Mustard

The Greeks used mustard as a condiment and a drug but it was the Romans who first made
real culinary use of it by grinding the seeds and mixing the flour with wine, vinegar, oil and honey.
When they moved into Gaul they took mustard plants with them and it was in the rich wine
growing region of Burgundy that mustard flourished.

It is reputed that at a festival in 1336 attended by the Duke of Burgundy and his cousin King
Philip the Fair, no less than 70 gallons of mustard were eaten. Reports do not say how pickled
the guests were.

Pope John XX11 of Avignon loved mustard so much that he created the post of "Mustard
Maker to the Pope," a job he gave to an idle nephew who lived near Dijon. Dijon soon became the
mustard centre of the world and in fact so important was it that in 1634 a law was passed to grant
the men of the town the exclusive right to make mustard.

1777 saw the start of mustard making as we know it today as it was in this year that Messieurs
Grey and Poupon founded their company. They used Grey's recipe and Poupon's money! We still
owe a lot to this redoubtable duo as in 1850 their company invented a steam operated grinding
machine so ending the era of laborious and back-breaking hand grinding,.

And as Jesus said in the Gospel of Thomas:

[The Kingdom of Heaven] is like a mustard seed. It is the smallest of all seeds; but when it falls
on tilled soil, it produces a great plant and becomes a shelter for birds of the air.

A Mustard Recipe

Ingredients

4 Tablespoons Dry mustard powder
1 Tablespoon White Wine Vinegar
2 Tablespoons Flat beer

1 Clove Garlic

1 Teaspoon Sugar

1/2 Teaspoon Salt

1/4 Teaspoon Turmeric

1 Tablespoon Olive oil -- optional

Preparation

1. Whisk together dry mustard, vinegar and beer.

2. Use a garlic press or large pair pliers to squeeze the juice from the clove of garlic into the
mixture.

3. Stir in sugar, salt and turmeric.

4. To make mustard smoother and less hot, add olive oil to taste.

Mustard Links

e  Européenne de Condiments

http://www.moutarde.com/
A mustard company's website

e  Mustard Gas

http://www.spartacus.schoolnet.co.uk/Fllmustard.htm
A description of mustard gas

. Mount Horeb Mustard Museum

http://www.mustardweb.com/
The world's largest collection of prepared mustards
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