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HomeSite Tutorial 
(version 1.1) 

This tutorial is designed to teach you some the basics of using Allaire HomeSite 4.5. 

Contents 
This tutorial will guide you through the following steps: 

1. Retrieving the necessary materials from the Web 
2. Configuring HomeSite 
3. Creating a HomeSite project 
4. Creating a Web page from "scratch" 
5. Converting a Microsoft Word document into a Web page 
6. Editing an existing Web page 
7. Getting your pages on the Web 
8. Cleaning up 

Prerequisites 
This tutorial assumes a level of competency with basic computing tasks and concepts.  For 
example, you should know what "the desktop" is and you should feel comfortable working with 
files and folders and navigating file hierarchies. 

Important: You will also need to understand the basic vocabulary and syntax of HTML. 

Conventions 
Actions that you need to perform are bulleted, like this: 

• Open the file. 

Menu commands look like this: File > Open.  This means choose the Open option from the File 
menu.  Sometimes, for the sake of brevity, common menu items may be referred to simply as 
Save or Open.  The same style is used for other user interface elements, such as key you're 
supposed to press and buttons you're supposed to click, i.e. "Click the OK button." 

HTML code and URLs look like this: 

<BODY BGCOLOR="white"> 

Names of files and folders, as well as text that you are supposed to type, are rendered in italics.  

Before You Begin: Configure Your System 
Follow these instructions to make Windows display filename extensions at all times.  This is 
highly recommended for aspiring Web authors, because it reduces opportunities for confusion. 

• Open any folder or drive. 
• From the View menu, choose Options or Folder Options.  A dialog box should appear. 
• Click the View tab. 
• Look for an option that says "Hide file extensions for known file types" or "Hide MS-DOS 

file extensions for file types that are registered."  Make sure this item is not checked. 
• Click the button marked OK. 
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1. Retrieve Materials 
First, you must create a folder to hold your files. 

• Create a new folder on the desktop and name it hositu.  You can do this quite simply by 
clicking on the desktop with your right mouse button and choosing New > Folder from 
the pop-up menu.  Then, without pausing to draw breath, type the word hositu.  Press the 
Enter key, and you're done. 

• Open up the folder you've just created and create another folder inside it.  Name this 
folder images. 

Next, you must retrieve the necessary materials from the Web. 

• Start Netscape, and point the browser to this URL: 

http://www.xula.edu/Administrative/cat/workshops/homesite/ 

• Find the section of the page under the heading Tutorial Materials. 

• Right-click on All_About_Mustard.doc and choose Save Link As… from the pop-up 
menu. 

• Save this file in the hositu folder you created earlier.  (You'll be prompted by Netscape.) 

• Right-click on coffee.html and choose Save Link As… from the pop-up menu.  Save this 
file in the hositu folder. 

• Right-click on mustard.jpg and choose Save Link As… from the pop-up menu.  Save this 
file in the images folder. 

• Right-click on wavetile16gzig.gif and choose Save Link As… from the pop-up menu.  
Save this file in the images folder. 

You should now have a Word document, a Web page, and two image files in your hositu folder — 
all the materials you need to complete this tutorial. 

• Close Netscape. 
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2. Configuring HomeSite 
As with many other programs, HomeSite gives you a lot of options for customizing the workspace.  
Unfortunately, the initial "out of the box" settings are not optimal in this author's opinion.  In 
fact, HomeSite may crash frequently if you don't disable certain "features."  Please take a few 
moments to configure your version of HomeSite according the steps below. 

2.1 Adjusting the Settings, Step by Step 

• Start HomeSite. 

• Choose Options > Settings. 

• Adjust the General settings first.  
Check the same boxes as in the 
figure shown here. 

• Under Tab style choose Text. 

 

• Use the left pane to select the 
HTML settings.  Adjust them 
according to the figure shown 
here.  

 

• Now adjust the Design settings.  
Make sure you disable the design 
tab!  The importance of this step 
cannot be overemphasized.  
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• Now adjust the Validation 
settings.  Make sure only the top 
three items in the list are checked. 

 

• Click the Validator Settings 
button.  A new dialog will open.  
Configure it according to the 
figure at right. 

• Click OK when finished and click 
OK again to save the new settings. 

 

2.2 Customizing the Toolbars 

• Choose Options > Customize. 

• Uncheck every item in the Visible 
Toolbars list except for Common. 

• Select Common from the list.  (Just 
click it). 

• Now add a few more buttons to this list.  
Do this by dragging them from the 
Toolbuttons list and dropping them on 
the picture of the toolbar. 

These are the buttons you should add:  
Quick list, Table wizard and Resource tab. 

 

• When you're finished, click Close to exit the dialog. 
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2.3 Reducing All That Clutter 
Maybe it's just me, but I'm kind of overwhelmed by all the 
little toolbars and windows that HomeSite first presents.  To 
temporarily get rid of stuff (or to bring it back later), use the 
View menu.  I recommend that you display only the items 
shown in the figure to the right. 

 

2.4 Progress Check 
HomeSite should now look something like 
the figure to the right.  If it doesn't, make 
sure you've followed all the steps above. 

 

 

• Experiment with the resource tab 
button in the Quick Bar.  This is a 
handy way to further reduce 
clutter and get more working 
space on the screen. 

 

Resource 
Window 

Resource 
Tabs 

Quick Bar 

Editor 

Editor 
Toolbar 
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3. Creating a HomeSite Project 
Yes, you could use HomeSite without taking advantage of its project management features.  But 
the real question is: Why would you want to do that?  By creating a project in HomeSite, you 
eliminate a number of the headaches associated with Web authoring -- especially checking links 
and uploading files to the Web server. 

• Click the Projects tab (bottom of the Resource Window). 

• Click the magic wand button to create a new project (or choose Project > New Project if 
you prefer). 

A dialog box will prompt you for the name and location of the new project. 

• For the Project Name enter HSTutorial. 

• Don't enter the Location manually.  Instead, click the folder icon.  You'll be prompted to 
browse to the location of your project files.  Navigate to hositu and select it. 

• For File Types choose All files. 

• Click OK. 

Wow.  That was easy.  What just happened?  HomeSite created a file (called HSTutorial.apf) in 
your hositu folder.  HomeSite will use this file to store information about your project. 

Your project window should now look something like this: 

 

• Take a moment to explore using the project tree to view your project files.  Make sure to 
look in hositu as well as images.  Don't neglect the project resources.  But leave the 
deployment stuff alone for now. 

your 
project 

files 

project 
tree 
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4. Making a Web Page from "Scratch" 

4.1 Getting Started 

• Choose File > New. 

• A dialog should appear.  Choose Default Template and click OK. 

This should give you a template like the following: 

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"> 
<html> 
<head> 
 <title>Untitled</title> 
</head> 
<body> 
 
</body> 
</html> 

 

Before going any further, save your work. 

• Choose File > Save and name the file home.html.  Make sure you are saving it in the 
hositu folder. 

• HomeSite will ask if you want to add this new file to your project.  Click Yes.  (Observe 
that home.html is now listed in the project window.) 

First you will title the document, then assign a background image, then add some text. 

• In the editor window, double-click the word Untitled to select it.  Then type a new name: 
My Fake Home Page. 

• In the Quick Bar, click the Body button and a dialog window will open.  This window 
allows you to customize the BODY tag. 

• Specify a background image.  But don't type the address in manually.  Click the folder 
icon and navigate to your images folder.  Select the wavetile16gzig.gif image and click 
the Open button. 

The Background Image field should now say images/wavetile16gzig.gif 

• Click the OK button to close the dialog box. 

Observe that the BODY tag has changed.  It should now say: 

<body BACKGROUND="images/wavetile16gzig.gif"> 

Now add some content to the page itself.  You'll start with a heading, then a paragraph. 

• Click between the BODY tags. 

Hint:  Don't click inside either tag.  Instead, click between the two tags -- in that blank 
space between the opening BODY tag and the closing BODY tag.  Get it? 

• Choose Tags > Heading 1. 

Note that HomeSite inserts a pair of H1 tags.  The text insertion point is between the two tags, so 
you can just start typing: 

• Type Welcome to My Fake Home Page. 

• Use your arrow key to move down to a new blank line.   (Create a new line if necessary.) 
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• Choose Tags > Paragraph. 

• Between the P tags, type some nonsense text for your fake page. 

Hint:  If you type very much, you may find the window starts to scroll to the left.  You can 
prevent this by clicking the little Word Wrap button on the Editor Toolbar. 

• Save your work. 

Your page should now look something like this: 

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"> 
 
<html> 
<head> 
 <title>My Fake Home Page</title> 
</head> 
 
<body BACKGROUND="images/wavetile16gzig.gif"> 
<H1>Welcome to My Fake Home Page</H1> 
<P>Hello and welcome to my fake home page.  It's not a real page.  I'm just 
making it up for this dumb workshop.</P> 
 
</body> 
</html> 

4.2 Browsing Your Page 

• Click on the Browse tab. 

There will be a brief delay.  After a few seconds, you should see your page appear, not as raw code, 
but as it would appear in a Web browser. 

In fact, what you are seeing really is a Web browser.  HomeSite has launched Internet Explorer  
"behind the scenes." 

As you continue through the rest of this tutorial, remember to click the Browse tab every so often 
to see how your pages are developing. 

• Return to the HTML editor by clicking the Edit tab. 

4.3 More Ways to Do the Same Thing 
You created the heading and paragraph by using the Tags menu.  But HomeSite offers a number 
of other ways to do the same thing. 

• Click in the blank line below your paragraph.  If you don't have a blank line, create one. 

• Click the paragraph icon in the Quick Bar. 

• Between the P tags inserted by HomeSite, type a sentence like this: 

Some of my interests include: 

• When you're finished typing, press the End key (on your keyboard) to go to the end of the 
line.  Then press your Enter key to insert a new line. 

Now you're going to create a list.  You may recall that lists in HTML are a bit more complicated 
than headings and paragraphs, because they are composed of nested tags.  But with HomeSite 
lists are easy. 

• Click the quick list icon in the Quick Bar. 

• A dialog box will open.   Choose the Unordered list style.   
Make sure that the Generate </LI> tags box is checked. 
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• Now click in the big blank area and begin entering the items in your list.  After each item, 
press the Enter key on your keyboard.  Enter as many items as you like, and make up 
whatever you like, but be sure to include mustard and coffee as two of the items. 

• When you're done, click the OK button. 

You should now have some code that looks something like this: 

<UL> 
 <LI>mustard</LI> 
 <LI>coffee</LI> 
 <LI>fine wines</LI> 
</UL> 

• Press the Enter key on your keyboard a couple of times to insert a few blank lines after 
the closing UL tag. 

Just in case you're curious, the only reason you're inserting blank lines is to make your code easier 
to read. 

Now you'll add a horizontal rule and an address to round out the page.   

You could add a horizontal rule by clicking the icon in the Quick Bar. 

Or you could choose Tags > Horizontal Rule. 

But you've already used those methods.  So here's a yet a third way to do the same thing. 

• Right-click in the editor, on one of the blank lines you just inserted. 

• Choose Insert Tag from the pop-up menu. 
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The tag chooser dialog will appear: 

 

The tag chooser allows you to browse for tags by category. 

• Select different categories in the left pane and observe how the listing in the right pane 
changes. 

• Select HTML Tags in the left pane. 

• Scroll in the right pane until you see HR, the tag for horizontal rule.  Double-click it. 

The tag editor dialog will appear: 

 

This allows you to set attributes for the current tag.  Note that we could have gotten to this same 
dialog much more quickly via the Quick Bar or the Tags menu. 

• In the tag editor, select Align: center, Width: 50%, Size: 1.   
Make sure to check the No Shading box. 

• When you're done, click OK to exit the tag editor and click Close to exit the tag chooser. 

Note that HomeSite has added the following code to your page: 

<HR WIDTH="50%" SIZE="1" NOSHADE> 

Of course, there's another way to enter code -- you can just type it.  Even in this scenario, 
HomeSite offers a few conveniences. 

• Press Enter to start a new line. 

• Press Ctrl+, (the control key and the comma key at the same time).  HomeSite will insert 
an empty start tag. 

• Type the word ADDRESS between the pointy brackets, the press the End key to go to the 
end of the line. 

• Now type some content for your address, like This page was created by Jane Doe on 
February 31st, 2001 or something similar. 
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• Press Ctrl+. (the control key and the period key at the same time).  HomeSite will insert 
an empty end tag. 

• Type the word ADDRESS between the pointy brackets. 

You should now have something like this: 

<ADDRESS>Page maintained by me and me alone.</ADDRESS> 

• Save your work. 

• See what the page looks like by clicking the Browse tab. 

4.4 Validation Time 

• Choose Tools > Validate Document. 

This tells HomeSite to check the syntax of your HTML.  A results window should pop up: 

 

If you're lucky, the results will say that there are no errors or warnings.  But if you have errors, 
they will be reported with details and line numbers. 

• If you have errors, fix them and re-validate. 

• Close the results window when you are done. 
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5. Converting a Microsoft Word Document 
A common goal for Xavier faculty is transforming content from a word processing document into 
a Web page.  Microsoft Word has a Save as HTML feature, but it is universally reviled for 
producing needlessly bloated files, not to mention invalid HTML. 

I recommend getting the plain text from your Word document and marking it up with the 
appropriate HTML tags. 

One way to do this is by saving the document as a "text only" file.  But there is a simpler way. 

5.1 It's Called Copying and Pasting 

• Open the file named All_About_Mustard.doc which you saved to your hositu folder.  
(Double-clicking the file's icon in the project window should cause HomeSite to prompt 
you for instructions.  Click the Open in Associated Program button.   Microsoft Word 
should open automatically.) 

• Take a moment to look over the document and familiarize yourself with its contents and 
general structure.  It should already be familiar if you've taken the Introduction to HTML 
seminar.  A copy of this document is attached to the end of this tutorial; you may find it 
more convenient to refer to the printed copy as you proceed. 

• Choose Edit > Select All to select all the text. 

• Choose Edit > Copy to copy the selected text. 

• Close Microsoft Word and return to HomeSite. 

• In HomeSite, create a new document by choosing File > New, this time clicking on the 
Blank Document icon. 

• Click the quick start icon in the Quick Bar. 

The Quick Start Wizard should open, asking you to define a TITLE and DOCTYPE for a new 
document. 

• For the TITLE, enter My Mustard Page. 

• For the DOCTYPE, choose HTML 4.0 
Transitional -- the first option in the pop-up 
menu. 

• Click the Next button. 

• Enter a short description in the appropriate 
box, something like: Mustard is the world's 
most fascinating condiment. 

• Leave the other boxes blank and click Finish. 
 

The Wizard closes, but another dialog opens very quickly.  Do you recognize it from the earlier 
part of this tutorial?  This is the window that allows you to customize the BODY tag. 

• Rather than specify a background image, choose a background color.  Choose Yellow 
from the pop-up menu.  Then click OK. 

• Click between the BODY tags. 

• Choose Edit > Paste.  The text you copied from Word should appear in the new 
document between the BODY tags.  Note that all the special formatting has been stripped 
away.  All that remains is plain text and line breaks (carriage returns). 
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Your document should now look something like this: 

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"> 
 
<HTML> 
<HEAD> 
<TITLE>Mustard Page</TITLE> 
<META HTTP-EQUIV="DESCRIPTION" CONTENT="the world's most fascinating condiment"> 
</HEAD> 
<BODY BGCOLOR="#FFFF00"> 
All About Mustard 
An Abbreviated History of Mustard 
The Greeks used mustard as a condiment and a drug but it was the Romans who first made real culinary 
use of it by grinding the seeds and mixing the flour with wine, vinegar, oil and honey.  When they 
moved into Gaul they took mustard plants with them and it was in the rich wine growing region of 
Burgundy that mustard flourished. 
It is reputed that at a festival in 1336 attended by the Duke of Burgundy and his cousin King Philip 
the Fair, no less than 70 gallons of mustard were eaten.  Reports do not say how pickled the guests 
were. 
Pope John XX11 of Avignon loved mustard so much that he created the post of "Mustard Maker to the 
Pope," a job he gave to an idle nephew who lived near Dijon.  Dijon soon became the mustard centre of 
the world and in fact so important was it that in 1634 a law was passed to grant the men of the town 
the exclusive right to make mustard. 
1777 saw the start of mustard making as we know it today as it was in this year that Messieurs Grey 
and Poupon founded their company.  They used Grey's recipe and Poupon's money!  We still owe a lot to 
this redoubtable duo as in 1850 their company invented a steam operated grinding machine so ending the 
era of laborious and back-breaking hand grinding. 
And as Jesus said in the Gospel of Thomas: 
 [The Kingdom of Heaven] is like a mustard seed. It is the smallest of all seeds; but when it falls on 
tilled soil, it produces a great plant and becomes a shelter for birds of the air. 
A Mustard Recipe 
Ingredients 
4 Tablespoons Dry mustard powder  
1 Tablespoon White Wine Vinegar  
2 Tablespoons Flat beer  
1 Clove Garlic  
1 Teaspoon Sugar  
1/2 Teaspoon Salt  
1/4 Teaspoon Turmeric  
1 Tablespoon Olive oil -- optional  
Preparation 
1. Whisk together dry mustard, vinegar and beer.  
2. Use a garlic press or large pair pliers to squeeze the juice from the clove of garlic into 
the mixture.  
3. Stir in sugar, salt and turmeric.  
4. To make mustard smoother and less hot, add olive oil to taste. 
 
Mustard Links 
§ Européenne de Condiments 
 http://www.moutarde.com/ 
A mustard company's website 
§ Mustard Gas 
http://www.spartacus.schoolnet.co.uk/FWWmustard.htm 
A description of mustard gas 
§ Mount Horeb Mustard Museum 
 http://www.mustardweb.com/ 
The world's largest collection of prepared mustards 
</BODY> 
</HTML> 

 

• Choose File > Save. 

• Name the file mustard.html and click the Save button, making sure to save the file in 
your hositu folder.  HomeSite will ask you if you want to add this document to your 
project: 

 

• Click Yes and note that mustard.html now appears in the project window. 

You've just created another Web page.  It's incomplete, to be sure, but take a moment to see how 
it looks in a Web browser: 

• Click the Browse tab. 
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Note how all the text runs together.  All the extra whitespace and line breaks are ignored by the 
browser.  You have not yet marked up any of the text, and so the text has no logical structure. 

• Click the Edit tab. 

5.2 Marking Block-Level Elements 
Now you will designate the basic structure of the text.  Each chunk of text must be designated as 
belonging to a block element such as a heading or a paragraph. 

• Select the first heading.  That's the line which reads All About Mustard.   

Hint:  To select the entire line quickly, click once in the left margin. 

• Since it's the heading for the whole page, mark it as a first-level heading  
by choosing Tags > Heading 1. 

The line should now appear as: 

<H1>All About Mustard</H1> 

Now you must continue to mark up the rest of the text.  This procedure requires you to exercise 
some judgment.  Refer to the printed Word document and other materials as you need them.  You 
should save your work often, and check your work in the browser often. 

Hint:  For cleaner, easier-to-read markup, insert carriage returns liberally, whenever you 
need them.  Remember that they will not be visible in the browser. 

• Mark all the headings.  Remember that headings range from H1 (most important) to H6 
(least important).  You've already marked a first-level heading, so mark up some second- 
and third-level ones. 

• Mark all the paragraphs. 

Hint:  There are six paragraphs total, and they're all in the first section of the document.  
Yes, the extended quotation is a paragraph.  

• Mark the extended quotation with BLOCKQUOTE tags.   

Hint:  The BLOCKQUOTE tags should surround the P tags. 

<BLOCKQUOTE><P>[The Kingdom of Heaven] is like a mustard seed. It is the 
smallest of all seeds; but when it falls on tilled soil, it produces a great 
plant and becomes a shelter for birds of the air.</P></BLOCKQUOTE> 

Things are getting a little cluttered now, so here's a trick that might make your life easier: 

• Right-click inside a P tag -- any P tag will do. 

• Choose Collapse All Identical Tags from the pop-up menu. 

This should cause all the P tags in the document to 
be collapsed -- temporarily hidden from view.  If 
you ever want to reveal this content, just right-
click and choose Expand All. 
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• Don't mark the ingredients as a list.  Instead mark this as a section of preformatted text 
with the PRE tag using the Insert Tag command. 

• To mark the ordered list (the one that is numbered), first delete the numbers.  (For extra 
credit: Why?)   Then select the entire list, right-click and choose Selection > Convert 
Lines to Ordered List from the pop-up menu. 

5.3 Dealing with Tricky Text 
The list of links presents some special challenges: 

• You definitely want to delete the § characters.  These are "extended characters," so called 
because they are not a part of the more limited character sets which are often used on the 
Internet. 

• Select the list, right-click, and choose Selection > Convert Lines to Unordered List 
from the pop-up menu. 

• Click the Browse tab. 

Notice that each line in the list has been marked up as a separate bulleted item.  Compare this to 
the original Word document and you will see this is not what you want.  In fact, there should only 
be three bulleted items in this list, each one consisting of multiple lines. 

• Click the Edit tab. 

• Choose Edit > Undo. 

• Manually delete some of the line breaks in this section, so that there are only three lines, 
like this: 

Européenne de Condiments http://www.moutarde.com/ A mustard company's...  

Mustard Gas http://www.spartacus.schoolnet.co.uk/FWWmustard.htm A ... 

Mount Horeb Mustard Museum http://www.mustardweb.com/ The world's ... 

Hint: Turn off word-wrapping for this task.  By using your End and Delete keys you 
should be able to do this fairly quickly. 

• Select all three lines, right-click, and choose Selection > Convert Lines to Unordered 
List from the pop-up menu. 

• Add a horizontal rule at the end of the page with the HR tag. 

• Click the Browse tab. 

OK, now there's three bullets.  That's progress.  But it still needs some line breaks. 

• Click the Edit tab. 

• Insert line breaks -- the BR tag -- in the appropriate places by using the BR icon in the 
Quick Bar.  I recommend pressing the Enter key after each BR tag you insert just to make 
the code easier to read. 

When you're done you should have something that looks like this: 

<UL> 
 <LI>Européenne de Condiments <BR> 
 http://www.moutarde.com/ <BR> 
 A mustard company's website</LI> 
 <LI>Mustard Gas <BR> 
 http://www.spartacus.schoolnet.co.uk/FWWmustard.htm <BR> 
 A description of mustard gas</LI> 
 <LI>Mount Horeb Mustard Museum <BR> 
 http://www.mustardweb.com/ <BR> 
 The world's largest collection of prepared mustards</LI> 
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</UL> 

• Click the Browse tab. 

Great.  It looks more or less like the original Word document now. 

5.4 Designating Links 
But come to think of it, this is a Web page, not a printed sheet of paper.  Why not make those 
URLs into clickable links? 

• Click the Edit tab. 

• Select the first URL.   

• Right-click and choose Copy from the pop-up menu. 

• Select the name of the website, Européenne de Condiments. 

• Make this selection into a link or anchor using the A tag.   
The quickest way is to click the anchor icon in the Quick Bar. 

• The anchor dialog should open.  In the HREF field, right-click and choose Paste from the 
pop-up menu. 

• Click the OK button. 

• Repeat this procedure on the other two websites in the list. 

• Click the Browse tab. 

The names of the websites should be highlighted now, to indicate that they are clickable links.  Go 
ahead and click one to see if it works. 

• Click the Edit tab. 

This page is almost finished.  You just need to add a footer similar to the one you created for 
home.html.  In fact, why type all that over again when you can copy and paste? 

• Return to home.html by clicking the tab at the 
bottom of the editor window.  

• Select the HR and ADDRESS elements from the bottom of the page. 

• Right-click and choose Copy from the pop-up menu. 

• Return to mustard.html and paste the copied text toward the bottom of the page, taking 
care to place it before the closing BODY tag. 

5.5 Marking Inline Elements 
Anchors or links are examples of inline elements (as opposed to block elements).  Now you will 
continue to designate the structure of the text at the inline level -- sometimes referred to as the 
"text level." 

• If necessary, expand any collapsed text by double-clicking on it. 

• Select the phrase 70 gallons. 

• Choose Tags > Italic. 

Note that the phrase is marked with EM tags to indicated emphasized text. 
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• Mark the phrase Gospel of Thomas as a citation with the CITE tag. 
(I'll let you figure out a way to do this on your own.) 

Images are inline elements too.  Adding images with HomeSite is pretty easy, and as per usual 
there are a few different ways to accomplish this.  You could, for example, click the image icon in 
the Quick Bar.  But here's another way: 

• Click in the line containing the opening BODY tag.   

• Go to the end of the line by pressing the End key, then press Enter to insert a new line. 

• In the project window, display the image files.  (There are a couple of different ways to do 
this.  See if you can remember how.)  You should see mustard.jpg listed as one of the 
images available in this project. 

• Drag mustard.jpg into the editor window and drop it in the blank line you just inserted. 

HomeSite understands that you want to add the image to the page and writes the following HTML 
for you: 

<IMG SRC="images/mustard.jpg" ALT="" BORDER="0"> 

• Specify alternate text by typing mustard plant as the ALT value: 

<IMG SRC="images/mustard.jpg" ALT="mustard plant" BORDER="0"> 

5.6 Validation Time 

• Choose Tools > Validate Document.  A results window opens with at least one error: 

ASCII value greater than 127 found, HTML documents should not contain these 
values. Consider using &#eacute; instead. 

It's that diacritical mark in Européenne that's causing the problem.  Extended characters of this 
sort should be encoded to ensure that they display properly. 

• Choose Search > Replace Extended Characters… 

• Select the first option in the dialog box that appears, and click OK. 

Note that the problematic text should now read Europ&eacute;enne.  The character has been 
encoded. 

• If you have other errors, fix them. 

• Re-validate. 

• Choose Tools > Verify Links.   

The results will appear in the results window, as HomeSite checks each link in the page for you.  

• Close the results window when you are done, and Save your work. 
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6. Editing an Existing Page 
Most Web pages get updated from time to time.  This section focuses on how you can use 
HomeSite to edit a Web page which already exists. 

6.1 Using Tag Insight 

• Use the project window to find and open coffee.html. 

• Click the Browse tag to see what the page looks like.  Make sure to scroll down and take a 
look at the table. 

• Click the Edit tab to return to the editor. 

• Click in the opening BODY tag, right before the closing bracket (>). 

• Press the spacebar on your keyboard. 

• Wait a second.  A contextual menu should appear.   

This is called "tag insight" and it provides an easy way to add 
attributes to any existing tag.  If you don't see a contextual menu, 
make sure that you have the tag insight option selected in the 
editor toolbar.  Then back up and repeat the previous steps. 

 

All three of these 
options in the editor 
toolbar should have 
that "pressed in" look. 

• Use your arrow keys to move down the contextual menu until you get to the BGCOLOR 
attribute. 

• Press the Enter key on your keyboard.  HomeSite inserts the BGCOLOR="" attribute for 
you. 

• Wait a second.  Another contextual menu should appear through the miracle of tag 
insight. 

• Choose the Custom… option (it should be selected by default) and press the Enter key on 
your keyboard. 

• The color picker dialog opens.  Use the slider to select a luminescence of 65.  Then click 
around in the spectrum box until you see a dark brown color appear in the box marked 
Color|Solid. 

• Once you've got a dark brown color selected, click the OK button to exit the dialog.  
HomeSite inserts the appropriate hex value for the color you chose. 

• Press the spacebar once and the contextual menu should appear again. 

• Use your arrow keys to move down the contextual menu until you get to the TEXT 
attribute. 

• Press the Enter key on your keyboard.  HomeSite inserts the TEXT="" attribute for you. 

• Wait a second.  Another contextual menu should appear. 

• Use your arrow keys to move down the contextual menu until you get to the White option 
and press the Enter key on your keyboard.  HomeSite inserts the appropriate hex value. 

Your BODY tag should now look something like this: 

<BODY BGCOLOR="#585232" TEXT="#FFFFFF"> 

Of course, the precise hex value you chose may vary. 
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• Click the Browse tag to observe the changes, then return to the editor. 

6.2 Using the Tag Editor 

• Right-click somewhere in the opening H1 tag and choose Edit Tag from the pop-up 
menu. 

The tag editor dialog should 
open.  This should look familiar 
to you, as you used a similar 
dialog earlier in this tutorial, but 
for a different tag. 

 

 

 
Hint:  Click the help 
icon to toggle a 
built-in help feature 
that provides more 
information than you 
probably need 
about any given tag. 

• Choose center for the Align attribute, then click OK. 

• Click the Browse tag to observe the changes, then return to the editor. 

6.3 Using the Tag Inspector 

• In the resource window, click the Tags tab so that tag inspector is showing (instead of the 
project window). 

The top pane of the tag inspector shows a hierarchical breakdown of the 
current document structure.  The bottom pane displays available options 
for the currently selected tag. 

• Use the tag tree (top pane) to explore the document a bit.  You 
may need to click the refresh icon in the upper right corner of the 
top pane.   

• Open up the BODY to reveal all the nested elements. 
Find the TABLE element and open it. 

You should notice that the TABLE element is composed of TR elements 
(table rows), which are in turn composed of TD elements (table data or 
individual cells). 

Notice that clicking on a tag in the tree selects that tag in the document 
itself. 

 

• Click on the <TABLE BORDER="1"> tag in the inspector. 

Note the list of option available in the lower pane.  For the BORDER attribute you should see a 
listing of 1, reflecting the existing code.  Now you'll add some more attributes to change the look 
of the table. 

• Click on CELLPADDING and type 5 and press Enter on your keyboard.  Notice that 
HomeSite inserts the following attribute into the TABLE tag: CELLPADDING="5" 

• For CELLSPACING type 0 (that's a zero) and press Enter on your keyboard.  Notice that 
HomeSite inserts the appropriate attribute into the TABLE tag. 
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• Click in the first TR element.  You may need to refresh the inspector if it won't select 
properly. 

• Click on BGCOLOR and select Black from the pop-up menu, then press Enter.  HomeSite 
should insert the appropriate attribute (with color encoded as a hex value) in the first 
table row. 

• Click the Browse tab to check your work. 

• Validate the document. 

• Save your work. 

6.4 Linking Documents 

• Return to editing mode. 

• Click the project tab to bring the project window to the front. 

• Select Resources > HTML Documents in the project window.  A listing of all your 
HTML documents should appear in the lower pane. 

• Double-click home.html to open it. 

• In the list of your interests, double-click on the word mustard to select it.  (Just select the 
word, not any code.) 

• From the project window, drag mustard.html into the editor and drop it onto the word 
mustard. 

HomeSite writes the appropriate HTML to make the link. 

• Repeat the process to link the word coffee with the file coffee.html 

• Browse, Validate, Save 

6.5 Extra Credit 

• If you have time, make a table using the table wizard in the Quick Bar. 



HomeSite Tutorial 

21 

7. Deploying Your Project 
The next step is to put these files on the Web.  To do this, they must be uploaded from your 
desktop computer to one of the Xavier Web servers. 

The server designated for personal pages is named xavier.xula.edu.  Your home directory is on 
this server.  It was created with your Xavier e-mail account. 

Remember that "directory" is just another term for "folder." 

In order to access your home directory, you will need to know your username and password.  () 

You may already be familiar with using File Transfer Protocol or FTP to upload your files to the 
server.  If so, you probably use an FTP client line WS_FTP or a similar program. 

HomeSite has an FTP client built into it, and in this section you will configure HomeSite to access 
you Xavier Web account, then use HomeSite to deploy your project -- to upload all the necessary 
files to the server. 

7.1 Setting Up 

• In the project window, right-click on Deployment Servers and choose Add FTP Server 
from the pop-up menu.  In the dialog box that opens, configure your FTP server. 

• Description: You can name it anything you 
want.  This is just for your reference. 

• Host Name: The name of the host for all XU 
personal accounts is xavier.xula.edu 

• Username: This is the part of your XU e-mail 
address before the @ symbol. 

• Password: If you've never done this before, 
your password is probably still the default 
password that was issued when your account 
was first created: xavier1.  You should change it 
as soon as possible.  

I think it's OK to leave the remaining blanks at their default values. 

• When you're finished, click OK.  Note that your server now appears in the project window 
under Deployment Servers. 

• Right-click HSTutorial and choose Properties.  Enter a single backslash \ for the 
deployment path. 

7.2 Using the Deployment Wizard 

• Click the deployment wizard icon, which is in the upper right corner of the project 
window. 

• Choose the Direct Deployment option in the dialog box that appears, then click Next. 

• Choose Remote RDS/FTP Deployment on the next screen.  Make sure the first two 
checkboxes are checked, then click Next. 

• The next screen should show you the server you set up in the previous section.  Confirm 
that it is checked and click Next, then click Finish. 
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A results window should pop open, reporting the 
progress of your deployment.  If each stage is 
successful, it should look something like the 
image to the right.  Check marks are good. 

 
 

7.3 The Moment of Truth 

• Exit HomeSite.  (You will probably be prompted to save your project.) 

• Start your favorite Web browser. 

• Go to http://xavier.xula.edu/username/hositu/  
(but replace username with your username) 

You should see your fake home page.  Congratulations -- you're a webmaster. 
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8. Cleaning Up 
Your username and password are in the project file you created, so you definitely do not want to 
leave these tutorial files on a shared lab computer.   

• Simply drag your hositu folder to the Recycle Bin. 

• Empty the Recycle Bin. 

• Shut down your computer. 

• Don't forget to turn off your monitor too! 

• Please fill out an evaluation form before you leave. 
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All About Mustard 
An Abbreviated History of Mustard 

The Greeks used mustard as a condiment and a drug but it was the Romans who first made 
real culinary use of it by grinding the seeds and mixing the flour with wine, vinegar, oil and honey.  
When they moved into Gaul they took mustard plants with them and it was in the rich wine 
growing region of Burgundy that mustard flourished. 

It is reputed that at a festival in 1336 attended by the Duke of Burgundy and his cousin King 
Philip the Fair, no less than 70 gallons of mustard were eaten.  Reports do not say how pickled 
the guests were. 

Pope John XX11 of Avignon loved mustard so much that he created the post of "Mustard 
Maker to the Pope," a job he gave to an idle nephew who lived near Dijon.  Dijon soon became the 
mustard centre of the world and in fact so important was it that in 1634 a law was passed to grant 
the men of the town the exclusive right to make mustard. 

1777 saw the start of mustard making as we know it today as it was in this year that Messieurs 
Grey and Poupon founded their company.  They used Grey's recipe and Poupon's money!  We still 
owe a lot to this redoubtable duo as in 1850 their company invented a steam operated grinding 
machine so ending the era of laborious and back-breaking hand grinding. 

And as Jesus said in the Gospel of Thomas: 
 [The Kingdom of Heaven] is like a mustard seed. It is the smallest of all seeds; but when it falls 
on tilled soil, it produces a great plant and becomes a shelter for birds of the air. 

A Mustard Recipe 

Ingredients 

4 Tablespoons Dry mustard powder  
1 Tablespoon White Wine Vinegar  
2 Tablespoons Flat beer  
1 Clove Garlic  
1 Teaspoon Sugar  
1/2 Teaspoon Salt  
1/4 Teaspoon Turmeric  
1 Tablespoon Olive oil -- optional  

Preparation 

1. Whisk together dry mustard, vinegar and beer.  
2. Use a garlic press or large pair pliers to squeeze the juice from the clove of garlic into the 

mixture.  
3. Stir in sugar, salt and turmeric.  
4. To make mustard smoother and less hot, add olive oil to taste. 

Mustard Links 
• Européenne de Condiments 

http://www.moutarde.com/ 
A mustard company's website 

• Mustard Gas 
http://www.spartacus.schoolnet.co.uk/FWWmustard.htm 
A description of mustard gas 

• Mount Horeb Mustard Museum 
http://www.mustardweb.com/ 
The world's largest collection of prepared mustards 


